Windows Media Center crashing after installing RecordedTV HD

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Windows Media Center crashing after installing RecordedTV HD

ualdayan
This post was updated on .
I first tried version 1.8, then tried installing the latest beta and both behaved the same way.  I'm getting many partial recordings, and when I check event viewer it keeps saying this:
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: ehrec.exe
P2: 6.1.7600.16385
P3: 4a5bd034
P4: mcstore
P5: 6.1.0.0
P6: 4ce7b873
P7: 929
P8: 0
P9: ystem.ArgumentException.B9B281FC
P10:


I've noticed that if I restart the computer and DON'T open RecordedTV HD things seem to work ok until I do open RecordedTV HD.  At that point even if I close Windows Media Center it seems recordings are still being cut off early with that error message appearing in my event viewer.  The only RecordedTVHD events I see are:
The remote server returned an error: (400) Bad Request.   at System.Net.HttpWebRequest.GetResponse()
   at RecordedTVHDService.Service1.GetArtwork(String imageUrl, String SaveArtworkPath) - imageUrl = http://d3gtl9l2a4fn1j.cloudfront.net/t/p/original - SaveArtworkPathC:\Users\Public\RecordedTVHD\Images\Backdrops\][Eating Alabama.jpg

Trying to create backdrop thumb error: C:\Users\Public\RecordedTVHD\Images\Backdrops\][Eating Alabama.jpgC:\Users\Public\RecordedTVHD\Images\Backdrops\][Eating Alabama.jpg   at System.Drawing.Image.FromFile(String filename, Boolean useEmbeddedColorManagement)
   at RecordedTVHDService.Service1.ResizeBackdropForThumbnail(String imagePath)


I'm not sure if these are related to that problem (the above problem with the partial recordings being the biggest problem), but if I try to turn on 'auto launch RecordedTV HD' Xbox 360 extenders will lock up if somebody pushes any buttons before the 30 seconds or so for RecordedTV HD.  Also, if I turn off my TV that's connected to the media center PC when I turn the TV back on it'll be at the desktop with Windows Media Center minimized.  If I maximize it with a mouse (remote doesn't seem to be able to do it with the green button like normal) it has an error message saying RecordedTV HD has stopped working.

Edit: One other thing I forgot to mention - is it normal to have hundreds of RecordedTVHDService.exe reported as running when I view disk activity in the resource monitor?