The Recorded TV HD Service service hung on starting. ????

classic Classic list List threaded Threaded
27 messages Options
12
Reply | Threaded
Open this post in threaded view
|

The Recorded TV HD Service service hung on starting. ????

Rew452
After applying yesterdays MS updates I am now getting this error. I un-installed and reinstalled and no dice, error remains.

But error does not occur if Recordtv HD is removed.

Anyway to fix?

Thanks
Rew


Log Name:      System
Source:        Service Control Manager
Date:          11/15/2012 4:49:58 PM
Event ID:      7022
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Wayne-PC
Description:
The Recorded TV HD Service service hung on starting.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
    <EventID Qualifiers="49152">7022</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2012-11-15T21:49:58.774546800Z" />
    <EventRecordID>172634</EventRecordID>
    <Correlation />
    <Execution ProcessID="720" ThreadID="724" />
    <Channel>System</Channel>
    <Computer>Wayne-PC</Computer>
    <Security />
  </System>
  <EventData>
    <Data Name="param1">Recorded TV HD Service</Data>
  </EventData>
</Event>
Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

MJT Software
Administrator
No idea at this point. It would help to know which update did it so I can test. Can you uninstall each update one by one and test to figure out which update breaks it?

http://www.sevenforums.com/tutorials/24373-windows-update-uninstall-update.html

You can order by the date it was installed.
Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

Rew452
This post was updated on .
Ah, OK, there were quite a few of them will try to do after dinner.

They were Framework 4 and Office 2010 updates.


Rew

One more thing, the service does load but it stalls win7 for about 30 secs or so.
Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

MJT Software
Administrator
I installed all of the Framework 4 updates last night and everything seems to startup just fine. I don't see how the Office 2010 updates would affect my service either.
Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

Rew452
Am on lunch but I am sorry, got tied up after dinner last night and did not get back to it.

Will work on it tonight. are there any caches or left overs that would need manual remove after removing RecordTV HD so I can do a clean install?

Thanks, really like RecordTV HD


Rew
Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

Rew452
for tonight I just restored to just before updates and all is well for now. I will tomorrow add updates back in and see if I can see what 's happening. will report back then.

Thanks
Rew
Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

drtdiver
same problem here. event viewer pointed me to recordedtvhd hanging on start up. this causes my system to hang for about 3 minutes when the computer is turned on. if i remove recorded tv hd the problem goes away. i havent been able to pinpoint what update caused this yet.
Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

drtdiver
if i set the service to delayed start the problem goes away. im thinking that the service is starting before other windows services that it depends on to start have not loaded yet the service hangs.
Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

Scott_L
In reply to this post by Rew452
I'm seeing the same thing. I'll try the delayed start approach for now.
Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

MJT Software
Administrator
In reply to this post by drtdiver
If that is the case I will probably just set it to delayed start as a default. That shouldn't be a problem. Thanks.
Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

MasterTom99
Hello,

I have the same problem since Windows 8 was installed. Starting the service takes 30...60s after rebooting the computer. As this is started before many essential tasks, I have to wait before using the PC. I tried to start the service delayed, but this is NO solution. All the other tasks are loaded in this case immediately, but when I go to the media center and select RTVHD quickly, the complete computer crashes as the service is still missing. Even when starting the service by hand long time after rebooting, it takes very long to finish this process. I had to uninstall your software and use the media center functionallity instead ;-(

What can be the reason why the start of the service takes so long? What are the dependencies?
In the Recorded TV folder normally a folder TempRec exists for the time shift files. I replaced this with a link called TempRec directing to a huge RAM disk. Could this be the reason for the problem? I did this many month ago and up to now had no problems with it.

RTVHD version 1.7.19
Windows 8 Pro
I uninstalled RTVHD, rebooted, deleted the folder and installed again, but still the same problem.
Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

MJT Software
Administrator
After looking at my code I really don't know why this would be. How many videos (estimate is perfectly fine) are in Recorded TV HD?
Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

MasterTom99
Hello,

in my "Recorded TV" folder are ~70...100 recordings. Should I clean this folder for testing, or use a different one?
When Windows is waiting for the service to be started, almost no Harddrive activity can be seen.

I mentioned before, that I use a RAM disk for the time shift files. More details what I did can be found on: http://www.hack7mc.com/2009/07/setting-up-a-ramdisk-scratch-drive-for-windows-7-media-center.html
Do you include the TempRec folder in your search?

If you have any ideas what to check, I will do for you, because I´m very interested to use RTVHD instead of the stock app, soon.

Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

MasterTom99
In reply to this post by MJT Software
Hello,
after many hours of testing I am even more confused. Let me give you my outcome. Maybe you have an idea. The problem is the same when using V1.7.3, V1.7.19 or 1.7.28. The problem is not related to my RAM disk, because it even happens when using the standard temprec folder. The problem does NOT occure, when there is only one *wtv file in the RecordedTV folder, but it happens when there are two files or more.
I started your settings program when the problem happens. There you can read "service is starting..." for a very long time (endless?). But when your service is not started at all, how could the problem depend on the content of the folder? Do you think, there is a Mediacenter task, that is checking the folder at (almost) the same time and this can block your service to start? I am using MediaBrowser, MusicBrowser, MediaControl and MCshoutcast as plugins. Is one of it incompatible? I can check this maybe tomorrow by uninstalling one by one. Or do you have a better idea?
Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

MJT Software
Administrator
That is very odd. Did you try putting in different WTV files? I'm just curious if one of them has some sort of corruption that is stopping the service from advancing... I'm just completely guessing.

What happens if you start the service with one recording, and then while the service is still running you move the other recordings back in? Does it identify all of them? After that if you try to restart the Recorded TV HD Service what happens?

I don't think there is an incompatible program. My guess is that one of the files is corrupted or there is some file or shortcut or something that for some reason the service is getting stuck on.
Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

MasterTom99
I made a new folder named RTVHD and copied all records to this folder. In your setting tool I selected this folder to be watched. So I had complete different folders for recording of MC and RTVHD. When starting the service, all records have been detected, but after rebooting the computer the problem occurs again.

When I want to start the service using the windos programm, it takes ~2min to fill the green waiting bar. Then a Window is opened with the message: The service "Recorded TV HD" on the local computer could not be started. Error 1053: The service did not respond to the start or control request in a timely fashion. So it looks like the service is waiting for something and does not answer to windows anymore.

Next Test: I used the settings program to stop and start the service. When there was only one file in the folder, the service was started very fast. When I put more files into the folder, the starting took more time. It takes almost one second longer for each additional file. This means the service is starting to recognise the files before the handling with windows is finished. Windows has to wait until this is finished before the task responses. I think normally there is no need to start the recognition at once, becaus there are no new files created while the computer was switched off. In the internet I found some hints that this problems might be related to the .NET framework.

Maybe you can make a versin of the service with additional logfile output? I can start it here and send you the logfile.

Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

MJT Software
Administrator
There was a version way back when, where I had it scan all the files on the service start and did it on the main thread. That is the type of issue it caused where it would say the service was starting for a really long time. I can't remember when I changed it and you said you've tried several versions.

What version are you running now? Does it ever move beyond the starting phase? How long have you left it go?

Please try the latest version I've got and let me know what happens: http://www.recordedtvhd.com/download/alpha/RecordedTVHDSetup.msi
Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

MasterTom99
Hello,
First I installed 1.7.3. This was updated to latest beta (1.7.9?) inside MC. For some tests I installed 1.7.28. I did not make all tests with all versions, but I am sure I had problems with all of them. I will install 1.7.28 again this night to find out if there are any differences. If it helps I can install a special version with debug output and send you the logfiles.
Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

MasterTom99
In reply to this post by MJT Software
When installing the latest alpha version I got an error messige "service can not be installed, because of missing privilegues". After clicking on retry it workes.

First start: service is started fast. Then all files are discovered with running task as it should be (green status bar is working). After ~2 minutes the service goes to idle.
Second start using your settings tool: Green Statusbar is active for two seconds, then status changes to idle BUT "Service is starting.." is still be shown. In windows service tool your service is shown as "starting", too. After ~2 minutes, the service is shown as running under windows and in your settings tool. The 2 minutes is the same time it takes to scan all files at the first start.

After rebooting Windows it takes additional 30s before all autostart programs are loaded. Reason for this can be found in the event log of windows: The service "Recorded TV HD" could not be started correctly. 30s is the standard timeout when a service does not respond. Nevertheless, after 2 minutes the service is running and works correctly.

Conclusion: Even in your latest alpha, one complete scan of all files is completed before the service is responding to windows.

Remark: I´m using a SSD. Did you test using a SSD? Could it be that the drive reacts faster than your SW expects?
Reply | Threaded
Open this post in threaded view
|

Re: The Recorded TV HD Service service hung on starting. ????

MasterTom99
In reply to this post by MJT Software
Hello,

is there any improovement in this problem? For me only uninstalling and using the original WMC function makes the computer usable again. But of cause this is not why I bought RTVHD. I found many people having problems with RTVHD+Windows8.
Is there any plan for further updates or do you now concentrate on MyMemories only?

12