Interface freezes when using commercial skip

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Interface freezes when using commercial skip

jamieacura
This post was updated on .
I'm using an Xbox360 as extender (haven't tested on Win7 machine itself).  When commercial skip is enabled, if I choose a show through the RecordedTVHD interface, the interface freezes.  The show will keep playing, but no longer skips commercials and the remote is no longer responsive.  I have to power off the Xbox and power back on.  When using the regular "Recorded TV" menu to play shows everything works fine, including commercial skip and the custom display showing where the commercials are.

EDIT:  Actually interface just froze using the regular recorded tv interface.  So maybe it's just the custom commercial skip display that's freezing things up....
Reply | Threaded
Open this post in threaded view
|

Re: Interface freezes when using commercial skip

craigwillie
I just experienced the same issue last night. Had to reboot the xbox several times to resolve.

I had just installed recorded tv hd in the past week. Never had this problem before that.
Reply | Threaded
Open this post in threaded view
|

Re: Interface freezes when using commercial skip

MJT Software
Administrator
I've had this randomly as well.... I cannot seem to find anyway to fix it yet because I have no idea what is causing it. I thought I had it fixed for about a week and then last night it happened again once.  I'll keep looking into it.  Thanks for reporting.
Reply | Threaded
Open this post in threaded view
|

Re: Interface freezes when using commercial skip

John Galt
Solution is to turn off the commercial highlighting option and restart the computer. Problem goes away. (and you don't get the kewl red bars in the progress bar)
Reply | Threaded
Open this post in threaded view
|

Re: Interface freezes when using commercial skip

MJT Software
Administrator
If you can, please try out the latest beta and let me know if you are still having issues with it. I've been testing my "fix" for at least a couple of weeks and I haven't had it freeze or stick on the media center background at all in that period. It also seems to be faster, but that just might be a placebo :)

Latest Beta Info and Download
Reply | Threaded
Open this post in threaded view
|

Re: Interface freezes when using commercial skip

John Galt

The hang appears to be gone! Thanks!

 

Still got a ton of episodes and movies that aren't being detected properly. Here's examples of file names:

 

Babylon 5.s05e05.mkv

Babylon 5.S04E19_Between_the_Darkness_and_the_light.mkv

The Terminator.wmv

The Last Starfighter (1984).wtv (meta-data is in the wtv file but it doesn't read it nor get it's own)

Ghost Rider Spirit of Vengence .avi (note the space)

Crusade.s01e01.avi

Dexter S01E02 - Crocodie.avi

Jericho - S01E02 - Fallout.mkv

 

Here's a regex that I did for DVRMStoolbox to get tv db database data so that it could automatically convert to WTV for me... works great... the conversion process not so much yet...

(?<series>.+?)[ \.-]+[ sS]*(?<season>\d+)[eExX](?<episodenbr>\d+).*

It matches and creates groups for Series, Season and episodeenbr

Which should be what you need. Just have to replace the _ and . in the series with spaces and you're good to go. (oddly as I write this I restarted the service and it got way more of them right...)

For movies I think it's working mostly ok except for WTV files and the trailing space.

All of these have meta data in the directory from other sources already. It would be awesome if it used it. For instance I have movie.xml in every directory. It has everything in it from my movies. (unencrypted now!) I also have dvdid.xml files for each.

Looking good! If the meta data stuff can be cleaned up and get more accurate so that I don't have to manually set all of these and wtvs will actually work properly as movies etc. we're golden!

Thanks again!

Jamie

 


-----Original Message-----
From: MJT Software [via Recorded TV HD Forum] <[hidden email]>
Sent: Jun/19/12 2:04 PM
To: John Galt [hidden email]
Cc:
Subject: Re: Interface freezes when using commercial skip



If you can, please try out the latest beta and let me know if you are still having issues with it. I've been testing my "fix" for at least a couple of weeks and I haven't had it freeze or stick on the media center background at all in that period. It also seems to be faster, but that just might be a placebo :)

Latest Beta Info and Download

If you reply to this email, your message will be added to the discussion below:

http://recorded-tv-hd-forum.1045789.n5.nabble.com/Interface-freezes-when-using-commercial-skip-tp5535588p5706759.html

To unsubscribe from Interface freezes when using commercial skip, click here.
NAML

Reply | Threaded
Open this post in threaded view
|

Re: Interface freezes when using commercial skip

MJT Software
Administrator
Thanks for the help with the regex. I'll see what I can do.
Reply | Threaded
Open this post in threaded view
|

Re: Interface freezes when using commercial skip

mogulman
I tried enabling the commercial skip display after I went to 1.7.6.   Initially, I thought it was fixed for me.     Watched some shows tonight though and got the blue screen after a bunch of skips.  Not sure if it is 1.7.7 or if it just wasn't fixed.  

I disabled the commercial skip display for now.