Application stops responding to remote.

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Application stops responding to remote.

we7313
I've had this happen to me about a dozen times now.  I finish watching a show (or hit back) and am unable to do anything on the menu it returns me to.  If I grab the mouse I can go back to other WMC menu, but recorded tv hd is still stuck even when I launch it again.  The only way to get it working again is to restart the entire media center app.

I've held off on reporting this because I've been trying to figure out how to reproduce it over and over again.
I've been unable to figure out what actions cause this.

Let me know what other information I can contribute to help solve this bug.

-Will
Reply | Threaded
Open this post in threaded view
|

Re: Application stops responding to remote.

MJT Software
Administrator
Hello Will,

I'm assuming this always happens when going back to the episode screen. Is this correct?  I'm not sure if you would really go back to another screen from watching something unless you back out while it is playing go to another screen and then go full screen from an alternate place.

I haven't seen this problem, but I'll take a look at my code and see if there is anything that might be causing that type of issue.
Reply | Threaded
Open this post in threaded view
|

Re: Application stops responding to remote.

we7313
It happens when returning to the episode screen, but it doesn't always happen.  This is not a newly introduced problem, I have seen it happen for over a month now (with all the new betas).

It looks like this problem was reported back on May 4th, "Remote keypress Lockup....".

My kids and I use this program all day.  So it gets a lot of use.  We can get it to happen daily now.
It also happens when I'm using it.  I only watch about an hour a day and don't do anything special.  Just watch, then delete, and hit back to get to the list of shows.

If I find a pattern I'll let you know.

-Will

Reply | Threaded
Open this post in threaded view
|

Re: Application stops responding to remote.

MJT Software
Administrator
I don't think the "Remote keypress Lockup..." thread has to do with the same thing. That one has to do with the fact that he deleted the recording outside of the Recorded TV HD plugin (using the standard recorded tv library) and then backed back into Recorded TV HD.  I don't think that is what is happening with you... is it?  If it is I have one idea.  If it isn't I'm not sure yet.
Reply | Threaded
Open this post in threaded view
|

Re: Application stops responding to remote.

we7313
Nope your right, thats not what I'm doing.  Maybe this has something to do when you fixed the bug of the show not being removed from the list after deleting it?

-Will
Reply | Threaded
Open this post in threaded view
|

Re: Application stops responding to remote.

MJT Software
Administrator
I don't think so. I just fixed that last week. You said it has been happening for over a month....

When a user gets back to the "Episode" screen my application does the following...
1. Refreshes resume data
2. Checks if it should show the "Stop Recording" or the "Delete" option.
3. Checks if it should show the "now playing" window.

My guess is that it is one of the first 2 things that might be hanging it up, but I'm not even sure of that. If for some reason it takes a long time on refreshing the resume data or gets stuck on it the UI might freeze.  

Now that I think about it I'm not sure if it would be the second one.... Do you know if the ones that lock up on you are older or have they been recently recorded like within the last 2 hours?

I'll make a couple changes to the code and send you a beta to try out and see if it still happens.