Anyone else having massive stability problems?

classic Classic list List threaded Threaded
17 messages Options
Reply | Threaded
Open this post in threaded view
|

Anyone else having massive stability problems?

pmrowley
I've installed the latest stable verson on a Win7 Pro installation, and it has caused nothing but headaches. 2 BSODs, system freezes, etc. I rolled back to the previous stable version, as this is my production MC box, and the wife was having fits.

Anyone else seeing massively degraded stability on this new version?
Reply | Threaded
Open this post in threaded view
|

Re: Anyone else having massive stability problems?

nathagt
Yes - also seeing stability issues. Freezes and the link. Further, when I uninstalled, the default TV menu strip does not come back! Does anyone know how to get this back or why Recorded TV is permanently disabling it?
Reply | Threaded
Open this post in threaded view
|

Re: Anyone else having massive stability problems?

MJT Software
Administrator
Sorry that you are having problems. I obviously would not have released this as a stable version if I didn't think it was stable. There has been a lot of beta testing going on with this version over the past while and I thought it was ready.

I have no idea why it would be causing BSOD or freezing problems, but I will look into it.

By default it keeps your setting for hiding the default tv strip because when you upgrade to a new version it will actually do a uninstall and then an install of the new version and I wanted to make sure that the setting stayed.

To get the default strip back you can either intstal Recorded TV HD again and use that to show the strip once again, or you can make this easy registry change: browse to HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Start Menu\Applications\Internal\{dde82191-ea23-4606-9d63-b92c809c31bb} and change the "OnStartMenu" value to false.
Reply | Threaded
Open this post in threaded view
|

Re: Anyone else having massive stability problems?

MJT Software
Administrator
In reply to this post by pmrowley
If there is anyway the problems could be reproducible, that would help me narrow it down. At this point I really don't have a clue what would have caused system instability between the last stable release and this one.
Reply | Threaded
Open this post in threaded view
|

Re: Anyone else having massive stability problems?

tradetek
In reply to this post by pmrowley
Yes, installed 1.8 on several machines and interestingly enough my 32 bit Win 7 machine was the least affected! Based on the behavior I was seeing on my 64 bit Win 7 machines with twice as much memory, I suspect that some of the issues (mainly the screen bouncing around between the menu bar and the episode list) I think that the 32 bit machine was simply slow enough to lessen the impact of the problem.

I didn't have any issues with the standard WMC TV strip disappearing, but I did have problems with all of the the Recorded TV HD WMC menu strip. The Movies icon disappeared as well as the Search and Live TV icons. They all showed as active in the RTVHD settings. I was able to resolve this by removing everything but RTVHD from the strip in settings, then exiting the app back to the WMC strips view, and then going back in and adding the ones that I want to the strip and all has been fine since. Note that I don't use the Genre or Favorites views.

I down-graded to the latest alpha version 1.7.19 and all has been well (except for the normal alpha issues).

Bill
Reply | Threaded
Open this post in threaded view
|

Re: Anyone else having massive stability problems?

MoRBiD MaNGLeR
At this point, is anyone using 1.8 and not experiencing stability issues?

MoRBiD
Reply | Threaded
Open this post in threaded view
|

Re: Anyone else having massive stability problems?

MJT Software
Administrator
First off, I am not ignoring these problems, but at this point I don't have much to go on.

Second, if everyone was having stability issues I would have thousands of people hounding after me. There are only a few in this post.

I am not denying there are issues. I am doing this as a side business/hobby and I am NOT of expert programmer caliber. I am in no way claiming that my coding is the most efficient and there are no problems

If anybody has any more details for me to go off, hopefully I can figure out where the problems lie.
Reply | Threaded
Open this post in threaded view
|

Re: Anyone else having massive stability problems?

bts0004
In reply to this post by MoRBiD MaNGLeR
Things have been running pretty smooth for me for the last several months.  I've been using most of the alphas/betas/RCs up to 1.8.  Maybe once a week I run into RTVHD crashing, but nothing that affects my entire system.

Just as a point of reference, and these may be entirely unnecessary, but the 2 settings I added that seem to have impacted the amount of freezes I have are to: 1) delay the startup of the service in the Windows Services admin tool; and 2) select the start a new instance of RTVHD when I return to the main menu.

Again, these may have nothing to do with my current stability, but ever since I started using these options several months ago, I've had a marked improvement on how well it performs.

I am running this on 2 separate machines, both Win 7 (64-bit), one is Pro and the other is Home.  I also have DVRMSTB installed, along with ShowAnalyzer.  Personally, I think any kinks I've experienced have come from those.  When I rebuilt my systems, I ran for a while without having either of those installed and had even fewer issues.

(Edit: I'm also using MCL)

Just wanted to give my positive $.02 on my experiences so far.
Reply | Threaded
Open this post in threaded view
|

Re: Anyone else having massive stability problems?

tradetek
In reply to this post by pmrowley
First MJT, I for one haven't felt ignored by you... if anything the amount of time you must devote to this awesome little app is great.

Now as for the current "issues", on my secondary machine I stopped the service, uninstalled the currently installed version (1.7.19 is what I had rolled back to) and then installed 1.8.0 using the .msi file.

At the same time, I updated my UltraVNC install.

Things have been much better since and I am updating my prior box back to 1.8.0 using the same process, but will not upgrade UltraVNC. If I have any issues with the install, I'll go back and redo everything including upgrading UltraVNC.

As for why UltraVNC is on the box... I use HippoRemote to control my WMC system and it uses VNC to interact with WMC.

Thanks,

Bill
Reply | Threaded
Open this post in threaded view
|

Re: Anyone else having massive stability problems?

Beaker1024
In reply to this post by MJT Software
Another fraction of users might have decided to ignore the 1.8.0 release / update as I did.

For some reason I decided to check the forum before doing the update (from the last beta before 1.8.0) saw the 3-5 threads started due to issues and hit "ignore this update" and have been waiting the next release.

Now I'm also awaiting the next release as I'd like to have the new My Channels XL supported but that's a secondary reason.

A note about the "updates" since I did hit "ignore" on the popup message I thought I'd try to induce an update (or offer to update) by going into the wrench settings and the update section.  Using the Check for update there doesn't offer the 1.8.0 again.  Which I would assume it would.  Thought the "Ignore" would only be to get the popup nag (for only that release #) to stop showing up.

So maybe people are like me waiting on a 1.8.1 for stability fixes and MCxl support thus not commenting on the forum?

PS - I have had very very little issues with 1.7.19 (once in 2 months RHDTD software hung / restart) which has also cause me to be hesitant to goto 1.8.0 since that stable version release notes don't show added features I need.
Reply | Threaded
Open this post in threaded view
|

Re: Anyone else having massive stability problems?

LanceWebb
I have not upgrade to 1.8.0, in wait and see mode.  I have been running 1.7.28 on Windows 8 which has been pretty stable for me.  All TV's connected to XBOX 360's.

Maybe once a week I will need to restart the RTVHD services or reboot.  Sometimes new recordings will not refresh or it will lockup and say RTVHD program not responding.

I bought MCL XL, but when I make any changes other than the defaults (Big Logos or More Rows) WMC will not even launch.  Is this what other people are experiencing with MCL XL and RTVHD?

I have been hesitant to upgrade to 1.8.0, stability is now key.  I like running the latest and greatest and understand there will be some issues and how to resolve them.  But it is not just me, the whole house using and loves RHDTV, but my wife and kids understand what to do or have the patience if there's an issue.

We really do appreciate all of the work you have put into RTVHD!  You really have changed TV for us!  

Let us know what we can do to help!
Reply | Threaded
Open this post in threaded view
|

Re: Anyone else having massive stability problems?

tradetek
In reply to this post by tradetek
Just an update that on my Win 7, 64 bit machine using the uninstall old, then install new method, my systems have been stable since the reinstalls (one for a week, the other for 2 weeks) It is more stable than 1.7.19.

Bill
Reply | Threaded
Open this post in threaded view
|

Re: Anyone else having massive stability problems?

MoRBiD MaNGLeR
In reply to this post by Beaker1024
My situation mirrors Beaker1024's.  Since the second number of the release number incremented, I checked the forum to see what the "major change" was.  When I saw the number of threads related to instability, I decided not to upgrade yet.  Normally I do the upgrades without hesitation, but I opted to wait on this one.  I haven't bought MCL XL yet but I intend to do so once RTVHD supports it and once more users step forward regarding 1.8 stability.  Like a lot of folks here, stability directly relates to the family's acceptance factor of RTVHD.  But let's be clear... RTVHD is a great product and I regularly sing its praises to anyone who will listen.  Thanks, MJT, for continuing to develop this wonderful product.

MoRBiD
Reply | Threaded
Open this post in threaded view
|

Re: Anyone else having massive stability problems?

carljanderson
In reply to this post by pmrowley
I am as well. At least once a week on either of my extenders (Ceton's - one on 320 firmware and the other on 304) I get the RecordedTVHD isn't responding message. My choices are Close Program and Cancel. I choose CLose Program , which puts me back into live TV and then go back to RecTVHD and it works.

When I had a ticket open with Ceton, they notcied some RecordedTVHD issues (I think I was on 1.7.27 or 28) and they asked me to uninstall. I do have the Sysinfo file they wanted from that (if you want it)

Once I saw 1.8 was other I thought I would give it a try and am getting the issue above.

On a different note, I just did open a ticket with Ceton for a (hopefully different issue). I did grab a sysinfo file as well, just for me right now. I hope there isn't some conflict between Ceton drivers and RecTVHD.

Reply | Threaded
Open this post in threaded view
|

Re: Anyone else having massive stability problems?

pmrowley
Perhaps it's an issue with 64 bit? That seems to be the common denominator here with the new code...
Reply | Threaded
Open this post in threaded view
|

Re: Anyone else having massive stability problems?

MJT Software
Administrator
I'm working on some speed (and hopefully stability) improvements now by streamlining some code that may be causing sluggishness and possibly "not responding" errors. ... I should have a beta out by the end of the week.
Thanks.
Reply | Threaded
Open this post in threaded view
|

Re: Anyone else having massive stability problems?

MJT Software
Administrator
Please try out the latest beta and let me know if it is any better (hopefully not worse )

Latest Beta Info and Download Link